Добро пожаловать на Ass1s. Пожалуйста, авторизуйтесь или зарегистрируйтесь.

Июль 21, 2024, 03:06

Вход в систему с именем пользователя, паролем и длиной сессии
Пользователи
  • Всего пользователей: 41
  • Последний: shoy
Статистика
  • Всего сообщений: 81
  • Всего тем: 19
  • Онлайн сегодня: 1
  • Максимальный онлайн: 34
  • (Окт. 01, 2023, 18:24 )
Сейчас на форуме
Пользователи: 0
Гостей: 1
Всего: 1
1 гость, 0 пользователей

Разделы

Разрыв страницы

Автор 1cgod, Окт. 10, 2023, 23:09

« назад - далее »

1cgod

Доброго времени суток. Как сделать так, чтобы вот эта линия разрыва автоматом ставилась после 3х расходников, при условии что если в расходнике больше 3х единиц товара, тогда после каждого расходника.
Правильно ли я понимаю, что нужно копаться где-то в печатных формах?
P.S Я супер новенький в 1с)

Cheese_0

Ищи в процедуре печати "ТабДок.ВывестиГоризонтальныйРазделительСтраниц()" его обрисуй в свои условия.

Cheese_0

Можешь процедуру скинуть, что нибудь придумаем тебе.

1cgod


Cheese_0


1cgod

Какой именно, тут очень много процедур и форм  :(

Cheese_0

ту процедуру которая вызывается при клике на нужную печать

1cgod

Завтра как найду (если найду), то скину, спасибо!

Извилина

#8
Отталкивайся от запроса и способа заполнения макета. Возможно хардкод :) , но я бы использовал булево флаг и счетчик:
Счетчик = 0;
цикл обхода ВыборкаДокументов
флаг = Ложь
если ВыборкаТоваров.Количество() >= 3 Тогда
   Флаг = Истина
обход ТабЧасти
Конец обхода ТабЧасти
Установка параметров Подвала и его вывод
Счетчик = Счетчик + 1;
Если Флаг Тогда
   ВывестиГоризонтальныйРазделительСтраниц()
КонецЕсли
Если Счетчик%3 = 0 тогда
   ВывестиГоризонтальныйРазделительСтраниц()
КонецЕсли;
Но опять же, всё зависит от запроса и от того, как формируется ТабДок :-\
Касательно же где найти. Если это типовая, скорее всего Процедура Печать в модуле менеджера,  далее смотри параметры в УправлениеПечатью.НужноПечататьМакет(Парам1, Парам2). Парам2 даст тебе подсказку какая функция нужна. Смотри в УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, Парам3, Парам4, ФункцияПечати(Парам5, Парам6)). Тебе нужна ФункцияПечати. что-то например ПечатьРКО(...)

1cgod

Вроде бы нашел)

Цитата: Cheese_0 от Окт. 11, 2023, 13:34  ту процедуру которая вызывается при клике на нужную печать

Процедура Печать(Команда)

ТабличныеДокументы = ТабличныеДокументыДляПечати();
УправлениеПечатьюКлиент.РаспечататьТабличныеДокументы(ТабличныеДокументы, ОбъектыПечати,
ТабличныеДокументы.Количество() > 1, ?(НастройкиПечатныхФорм.Количество() > 1, Копий, 1));

// СтандартныеПодсистемы.УчетОригиналовПервичныхДокументов
Если ОбщегоНазначенияКлиент.ПодсистемаСуществует("СтандартныеПодсистемы.УчетОригиналовПервичныхДокументов") Тогда
СписокПечати = Новый СписокЗначений;
Для Каждого ПечатнаяФорма Из НастройкиПечатныхФорм Цикл
СписокПечати.Добавить(ПечатнаяФорма.ИмяМакета, ПечатнаяФорма.Название);
КонецЦикла;
МодульУчетОригиналовПервичныхДокументовКлиент = ОбщегоНазначенияКлиент.ОбщийМодуль("УчетОригиналовПервичныхДокументовКлиент");
МодульУчетОригиналовПервичныхДокументовКлиент.ЗаписатьСостоянияОригиналовПослеПечати(ОбъектыПечати, СписокПечати);
КонецЕсли;
// Конец СтандартныеПодсистемы.УчетОригиналовПервичныхДокументов

Оповестить("ТабличныеДокументыНапечатаны", ТабличныеДокументы, ОбъектыПечати);

КонецПроцедуры

1cgod

Есть еще такая часть кода в процедуре "Процедура НастроитьВидимостьЭлементовФормы(Знач ЕстьРазрешенныйВывод)"

Элементы.ГруппаНастройкаКомплектаКонтекстноеМеню.Видимость = ДоступнаНастройкаКомплекта;
Элементы.ГруппаНастройкаКомплектаКоманднаяПанель.Видимость = ЭтоПечатьКомплекта() И ДоступнаНастройкаКомплекта;
Элементы.НастройкиПечатныхФормПечатать.Видимость = ДоступнаНастройкаКомплекта;
Элементы.НастройкиПечатныхФормКоличество.Видимость = ДоступнаНастройкаКомплекта;
Элементы.НастройкиПечатныхФорм.Шапка = ДоступнаНастройкаКомплекта;
Элементы.НастройкиПечатныхФорм.ГоризонтальныеЛинии = ДоступнаНастройкаКомплекта;

1cgod


Извилина

Цитата: 1cgod от Окт. 16, 2023, 21:59  где все(
Все здесь) Какая это конфигурация? типовая или самописная?

1cgod


1cgod


Чат Полянка

Cheese_0:
2023-10-12, 12:25:42
Datamax особенно
Где Дэн?:
2023-10-12, 09:20:15
этикетки и принтеры это то еще удовольствие  ;D
Cheese_0:
2023-10-11, 12:07:24
Уууу я вернулся, 2 дня принтер для этикеток пытался настроить хахаха
Где Дэн?:
2023-10-09, 20:58:50
Потихоньку наполняю форум полезными темами и решениями, с которыми сам сталкиваюсь на практике.
Где Дэн?:
2023-10-08, 19:36:57
видос закинул веселый) на ютубчике - немного творчества в выходные
Где Дэн?:
2023-10-04, 23:22:59
Для незарегистрированных пользователей так же будет потихонечку пополняться пул обработок, доступных для скачивания и без регистрации....
Где Дэн?:
2023-10-04, 22:37:42
да, есть такое. Пускай здесь пока побудет - вроде не мешается и если что то можно блок с ним свернуть...что бы глаза не мазолил
Cheese_0:
2023-10-04, 22:35:59
Сразу чат стал удобнее
Где Дэн?:
2023-10-04, 22:33:31
файлы немного накидываю для зарегистрированных пользователей. Думаю скоро весь пул файлов полезных что есть здесь будет
Где Дэн?:
2023-10-04, 22:32:44
че за звезды? В принципе если так поговорить кому надо или спросить по быстрому оперативно - при наличии народа на сайте, то чат думаю удобно
Где Дэн?:
2023-10-04, 22:29:34
Да, перетащил его в другой блок) ;D
Cheese_0:
2023-10-04, 22:27:17
Где 5 звезд поставить?
Cheese_0:
2023-10-04, 22:27:06
ооооо чатик стал больше
Где Дэн?:
2023-10-04, 07:40:10
Что бы научиться программировать нужно всего лишь раз в день по утрам... ;D ;D
1cgod:
2023-10-03, 22:56:39
как же приятен форум без всяких реклам)